1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

MP3s spielen unter Firefox teilweise nicht

Dieses Thema im Forum "Allgemeines" wurde erstellt von macingosh, 21. Mai 2015.

  1. macingosh

    macingosh Member

    Registriert seit:
    12. März 2013
    Beiträge:
    14
    Zustimmungen:
    0
    Hallo,

    ich habe bei einer Seite mit vielen Soundfiles das Problem, dass diese unter Firefox teilweise nicht spielen. Wenn man in den Beiträgen, z. B. MDR Sachsen-Anhalt oder NDR Kultur, die Audios schnell durchblickt, also nicht zuende spielt, lassen sich einige Soundfiles nicht mehr abspielen und es sieht dann so aus:
    Den Anhang 12276 betrachten
    Das Problem kann aber wohl grundsätzlich auftreten, wenn man viele Audios nacheinander anhört.
    An den Dateien selber oder der Einbindung liegt es wohl nicht. Wenn man die Seite ein zweites Mal ansteuert, spielen zum Beispiel mp3s, die vorher problemlos liefen nicht und umgekehrt.

    Generell scheint der Firefox mit dem integrierten Player Probleme zu haben. So erscheint auf der rechten Seite nicht die Gesamtlaufzeit, sondern der gleiche Wert wie links, also die aktuelle Spielzeit. Außerdem verkürzt sich der jeweilige Player um geschätzte 20 Pixel, sobald man die Starttaste drückt. Auch die Progress-/Ladebalken laufen oft nicht so, wie sie sollten.
    Siehe hier:
    Den Anhang 12277 betrachten
    Anscheinend alles reine Firefox-Probleme. Hat eventuell jemand eine Erklärung oder Lösungsvorschlag?

    Danke und Gruß
     
  2. SuMu

    SuMu Well-Known Member

    Registriert seit:
    5. Januar 2006
    Beiträge:
    6.148
    Zustimmungen:
    42
    Chrome?! oder mal den Firefox beta testen.
     
  3. macingosh

    macingosh Member

    Registriert seit:
    12. März 2013
    Beiträge:
    14
    Zustimmungen:
    0
    Auf allen anderen Browsern (Safari, Chrome, Opera und wohl auch auf dem Explorer) läuft es sowieso tadellos. Nur Firefox macht Zicken. Die Gesamtlaufzeit wird nicht richtig dargestellt, der Progressbalken springt gleich bis ans Ende und beim Klick auf die Starttaste verkürzt sich der Player in der Breite. Und teilweise gab es bei einigen Nutzern wohl auch das Problem, dass beim schnellen Durchklicken durch die Audios einige dann gar nicht mehr spielen. Statt der Gesamtlänge steht dann NaN:NaN dort.
     
  4. Frank9652

    Frank9652 Well-Known Member

    Registriert seit:
    10. Juni 2011
    Beiträge:
    727
    Zustimmungen:
    5
    Hallo Macingosh!

    Ich vermute bei dir ein Syntaxproblem.
    Am Anfang wollten manche MP3's bei mir auch nicht funktionieren, bis ich festgestellt hatte, dass der MP3-Player ein bischen sensitiv ist. Er wollte keine deutschen Umlaute und keine Leerzeichen in den Soundfilenamen haben, und die Dateiendung will er immer klein geschrieben haben. Seitdem ich diese Regeln befolge, habe ich keine Probleme mehr.

    Bei mir liegen alle MP3's im Verzeichnis mp3.
    Anbei die Syntax, wie ich meine Soundfiles einbinde:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Ich persönlich bette die Syntax in eine Tabelle ein, hier ein Link zu meiner MP3-Seite als Beispiel.
    Vielleicht hilft dir das irgendwie weiter.

    Gruß Frank
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden