1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Multisite mit Subdomains und A-Record Strato

Dieses Thema im Forum "Installation" wurde erstellt von smokeymcpart, 10. Juni 2017.

  1. smokeymcpart

    smokeymcpart New Member

    Registriert seit:
    10. Juni 2017
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo Leute,
    bin nach verzweifelter Suche nach einer Lösung letztendlich hier gelandet und hoffe, hier kann mir jemand helfen

    Zum Thema:

    Ich habe heute nachmittag eine Wordpress Installation von Single- auf Multisite gestellt. Das hat auch wie immer wunderbar geklappt. Da auf der Seite schon Inhalte hinterlegt waren, wurde ich gezwungen, die Subdomain-Variante zu nutzen. Das ist auch nicht weiter schlimm, da ich das ohnehin machen wollte.

    Leider bekomme ich die im Wordpress und bei Strato angelegten Subdomains nicht zum laufen. Auf Strato sind lediglich alle Domains gesichert, kein Hosting


    Die Hauptseite "http://www.gewerbeimmobilien-erfolgreich-verkaufen.de/" läuft wunderbar (die Domain liegt bei Strato und ist per A-Record auf eine feste IP-Adresse geleitet)
    Sobald ich jedoch die Multisite-Funktion von Wordpress nutzen möchte und eine neue Subdomain (zb. test.gewerbeimmobilien-erfolgreich-verkaufen.de" anlege, erhalte ich weder Zugriff auf das Frontend, noch das Backend, obwohl die Subdomain bei Strato angelegt wurde.

    Testweise habe ich bei einer anderen Wordpress-Installation, auf die ich ebenfalls Zugriff habe, auch Multisite mit Subdomains aktiviert. Da habe ich in der Confixx Verwaltung dann einfach nur die entsprechende Subdomain angelegt und fünf Minuten später konnte ich Back- und Frontend erreichen. Alles wunderbar. Bei Strato jedoch keine Chance!

    Daher ist meine Vermutung, dass es irgendwie an der A-Record Weiterleitung liegt...Hab den ganzen Nachmittag getestet und gelesen und gewühlt...

    Nun noch ein Wort zu meinem eigentlichen Vorhaben:
    Wollte EINE EINZIGE Wordpress Installation nutzen, um mehrere Landingpages (4-5 verschiedene) zu verwalten (Vorteile brauche ich wohl nicht erläutern). Da für diese Landingspages auch mit Adwords geworben werden soll, sollte die Domain (die bei Strato gesichert wurde und die in der Anzeige angegeben wird) auch mit der letztendlichen Ziel-Domain übereinstimmen. Google lässt das gar nicht anders zu.

    Bis heute war die ganze Sache so gelöst:

    Wordpress Installation auf www.landingpage-pool.de (A-Record auf feste IP)
    Landingpage 1: www.landingpage-pool.de/LP1 (externe Weiterleitung von www.LP1.de)
    Landingpage 2: www.landingpage-pool.de/LP2 (externe Weiterleitung von www.LP2.de)
    Landingpage 3: www.landingpage-pool.de/LP3 (externe Weiterleitung von www.LP3.de)
    Landingpage 4: www.landingpage-pool.de/LP4 (externe Weiterleitung von www.LP4.de)

    So brauchte ich keine Multisite Installation, da die einzelnen Landingpages nur als Unterseiten angelegt waren. Nur hat wie gesagt Google bei Adwords etwas dagegen wenn in der Anzeige www.LP1.de steht und der User auf www.landingpage-pool.de/LP1 landet

    Daher die angestrebte neue Lösung:
    Wordpress (Multisite-)Installation auf www.landingpage-pool.de

    dann Subdomains:
    LP1.landingpage-pool.de
    LP2.landingpage-pool.de
    LP3.landingpage-pool.de
    LP4.landingpage-pool.de

    Dann Mithilfe von Wordpress Multisite Domain-Mapping die Subdomains mit der eigentlichen Domain der Landingpage verwursten. Bis zu diesem Schritt habe ich es jedoch nie geschafft, da ich ja noch nicht einmal auf die unter Wordpress neu angelegten Unterseiten gekommen bin.

    Ich hoffe, ich konnte irgendwie annähernd klar machen, was ich Vorhabe und wo mein Problem ist. Falls noch weitere Informationen benötigt werden, einfach kurz schreiben. Ich versuche so schnell wie möglich mit den benötigten Infos um die Ecke zu kommen.

    Danke euch schon mal!
     
  2. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Das Problem liegt weniger bei Strato, als vielmehr bei dem Webhoster, wo die Seiten selbst liegen, also wo der Webserver läuft.

    Dort mußt Du natürlich die Subdomains auch eintragen/konfigurieren, denn sonst weiß der Webserver nichts mit den Subdomains anzufangen.

    Der A-Record bei Strato macht ja nichts weiter, als zu einem Domain-Namen (Subdomain-Namen) die passende IP-Adresse zu liefern. Die restliche Konfiguration muß bei dem Webhoster erfolgen, wo der Webserver läuft.

    Gruß
    Ingo
     
  3. smokeymcpart

    smokeymcpart New Member

    Registriert seit:
    10. Juni 2017
    Beiträge:
    2
    Zustimmungen:
    0
    Danke dir! Das Thema hatte sich in der Zwischenzeit auch erledigt. Es lag exakt an dem Thema, das du berschreibst. Der Betreiber des Webservers hat nur bestimmte Domainanfragen angenommen. Das war mir in dem Moment leider nicht bewusst. Mittlerweile ist es so konfiguriert, dass jede mögliche Subdomain-Anfrage akzeptiert wird, ich also jederzeit Subdomains anlegen und ändern kann.

    Danke nochmal!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden