1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Nochmal Strato und php.ini

Dieses Thema im Forum "Installation" wurde erstellt von macbenutzer, 29. Juli 2007.

  1. macbenutzer

    macbenutzer Active Member

    Registriert seit:
    4. Dezember 2006
    Beiträge:
    29
    Zustimmungen:
    0
    Hallo, ich habe auch das Upload-Problem mit Strato und MyGallery (Abbruch des Upload bei Dateien >2MB). Diesen Thread habe ich auch gelesen und umgesetzt.

    Trotzdem die Frage: ich habe im Wurzelverzeichnis und im Ordner "wp-admin" die neue "php.ini" liegen (Original php.ini-Datei mit geänderten Werten bei memory_limit und upload_limit"). Wenn ich aber über "phpinfo" nachschaue, welche "php.ini" geladen wird, ist das immer noch die Strato-Originaldatei vom 23. May 2007.

    Wieso wird meine neue php.ini nicht geladen? Irgendeine Idee? Danke.
     
  2. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    23. Mai 2007 ist das Datum der PHP-Version. Das hat nichts mit der ini-Datei zu tun.
    Welche ini-Datei verwendet wird, wird bei Configuration File (php.ini) Path angezeigt.
    Steht dort sowas wie "/opt/RZphp4pl/etc/php.ini" ist es die Strato-Konfiguration.
    Steht dort aber sowas wie "/mnt/web1/23/45/678901234/htdocs/php.ini" ist es Deine eigene.

    Gruß
    Ingo
     
  3. macbenutzer

    macbenutzer Active Member

    Registriert seit:
    4. Dezember 2006
    Beiträge:
    29
    Zustimmungen:
    0
    Hi,
    danke für die Nachhilfe :)

    Bei Path steht: Configuration File (php.ini) Path /opt/RZphp4pl/etc/php.ini

    Also die falsche Datei - warum?
     
  4. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Was ist denn die "Original php.ini-Datei", die von Strato?
    Schreib doch einfach nur die Werte rein, die geändert werden sollen. Das reicht. Einfach so:
    Vieleicht liegt es ja daran, daß irgendein Wert nicht zulässig ist, und deshalb Deine ini-Datei ignoriert wird.

    Gruß
    Ingo
     
  5. macbenutzer

    macbenutzer Active Member

    Registriert seit:
    4. Dezember 2006
    Beiträge:
    29
    Zustimmungen:
    0
    Hallo Ingo,

    mir "Original" meine ich die php.ini-Datei, die man bei "php.net" downloaden kann (als Komplettpaket php).

    Deinen Hinweis aus dem genannten Thread habe ich natürlich auch schon versucht, aber ohne Erfolg. Die Werte bleiben bei 2MB und der Pfad bleibt beim "Strato-Pfad". Egal welche Schreibweise (<?php memory_limit = "16M"?> oder memory_limit = "16M").

    Ich komme nicht weiter... Strato sagt auch, ich müsste die Datei nur in das Wurzelverzeichnis legen, dann würe sie wirksam - das klappt aber nicht!

    ???
     
  6. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Die php.ini aus dem Download von php.net ist schon mal schlecht. Strato hat in der eigenen bestimmt Anpassungen drin, die dadurch außer Kraft gesetzt werden würden (Pfade, Module usw.). Eventuell wird die php.ini dann deshalb ignoriert.

    Also einfach eine Datei nur mit den gewünschten Werten, kein <?php ?> und sowas alles, keine anderen Werte verändern.
    Das mit dem "nur in das Wurzelverzeichnis" ist auch Quark, das trifft auf die .htaccess zu, welche ihre Einstellungen auch auf Unterverzeichnisse "vererbt". Bei der php.ini ist das nicht so, die muß in jedes Verzeichnis. Ich habe es ja ausprobiert.

    Gruß
    Ingo
     
  7. macbenutzer

    macbenutzer Active Member

    Registriert seit:
    4. Dezember 2006
    Beiträge:
    29
    Zustimmungen:
    0
    Ok - ist gelöscht.

    Habe ich jetzt so umgesetzt.

    Das hat Strato mir geschrieben - ich dachte, die wüssten, was sie tun...

    In welches Verzeichnis sollte ich diese Mini-php denn kopieren? Ins Wurzelverzeichnis und wp-admin. Wohin noch? Die 2MB Grenze bleibt bestehen :(

    Update: die erste Reaktion: wenn die Datei im Ordner wp-admin liegt (nur da, sonst keine andere) bekomme ich folgende Meldung:
    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 253 bytes) in /mnt/web2/10/46/5324446/htdocs/wp-includes/gettext.php on line 161

    Immerhin etwas...

    Gruss - Peter
     
    #7 macbenutzer, 29. Juli 2007
    Zuletzt bearbeitet: 29. Juli 2007
  8. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Ja, in die WP-Wurzel und ins /wp-admin-Verzeichnis. Die Datei muß php.ini heißen und Leserechte für alle haben. Versuch doch mal, die php.ini direkt im Browser aufzurufen, also z.B. www.example.com/php.ini. Dann sollte sie einfach als Textdatei angezeigt werden.
    Das ist z.B. meine:
    http://schnurpsel.de/php.ini

    Gruß
    Ingo
     
  9. macbenutzer

    macbenutzer Active Member

    Registriert seit:
    4. Dezember 2006
    Beiträge:
    29
    Zustimmungen:
    0
    Also:
    bei Deiner vorgeschlagenen Schreibweise bekomme ich sie im Browser angezeigt - (bei der im anderen Thread vorgeschlagenen Schreibweise kommt der fatal-error).

    Wie kann ich denn nun noch den Wert für "upload_max_filesize" ändern?

    So?
    memory_limit = "16M"
    upload_max_filesize = "8M"

    Siehe: http://www.fostar.de/wp-admin/php.ini

    Danke schon mal!
     
    #9 macbenutzer, 29. Juli 2007
    Zuletzt bearbeitet: 29. Juli 2007
  10. Iunius

    Iunius Well-Known Member

    Registriert seit:
    29. September 2006
    Beiträge:
    245
    Zustimmungen:
    1
    Beispiel einer php.ini bei Strato:
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Funktioniert sowohl im Stammverzeichnis als auch direkt im Plugin-Verz. von MyGallery.

    Gruß
     
  11. macbenutzer

    macbenutzer Active Member

    Registriert seit:
    4. Dezember 2006
    Beiträge:
    29
    Zustimmungen:
    0
    Hi,

    vielleicht geht es schon eine ganze Weile...???:
    ich habe die ganze Zeit die phpinfo über das PlugIn "myGallery" aufgerufen (diese Option gibt es da unter "Info" ganz rechts). Dabei wird mir immer die Stratodatei angezeigt.

    Jetzt habe ich mir eine eigene phpinfo-Datei im Wurzelverzeichnis angelegt mit folgendem Inhalt:
    (<?php
    phpinfo();
    ?> ​

    Jetzt wird mir wunderbar alles inkl. meinen Änderungen angezeigt - auch der Pfad lautet nun anders.

    Ich probiere mal einen Upload (+2MB dauert halt bei 192kb/s - mehr gibt es in meiner Strasse nicht).

    Peter
     
  12. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Das ist ein schönes Beispiel dafür, das die php.ini eben nur in dem Verzeichnis wirkt, wo sie auch steht und die php-Datei aufgerufen wird, für die die Einstellungen gelten sollen. Es reicht nicht, sie ins Wurzelverzeichnis zu legen (wie angeblich der Strato-Support behauptet).

    Gruß
    Ingo
     
  13. macbenutzer

    macbenutzer Active Member

    Registriert seit:
    4. Dezember 2006
    Beiträge:
    29
    Zustimmungen:
    0
    Eine Nachricht von Strato (sie habe wohl dazugelernt):
    "Bitte beachten Sie, dass eine php.ini nicht in Unterverzeichnisse vererbt wird. Das bedeutet, dass in jedes Verzeichnis, wo die Einstellungen greifen sollen, eine eigene php.ini vorhanden sein muss."

    Allerdings bricht das PlugIn "myGallery" immer noch ab, ich konnte aber bisher noch keine "Regel" feststellen. Vielleicht frage ich den Entwickler oder suche mir ein anderes PlugIn...

    Dank an alle, die mir geholfen haben!
     
  14. samsonb

    samsonb Active Member

    Registriert seit:
    12. Februar 2007
    Beiträge:
    31
    Zustimmungen:
    0
    Hallo,
    ich habe wohl auch das selbe Problem wie viele andere:
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3072 bytes) in /www/htdocs/baliro/wp-content/plugins/mygallery/myfunctions/mygalleryfunctions.php on line 376

    also ich habe die sache mit der Sprachdatei aus den FAQ befolgt.
    Habe eine alte mygallery version versucht. auch kein erfolg.
    hab alte gallerien per ftp und bei mygallery gelöscht.
    hab es mit einer anderen php.ini versucht.

    von haus aus:
    max_execution_time 30
    max_input_time 60
    memory_limit 32M

    aber alles leider ohne erfolg.
    Gruß simon
     
  15. macbenutzer

    macbenutzer Active Member

    Registriert seit:
    4. Dezember 2006
    Beiträge:
    29
    Zustimmungen:
    0
    Immer noch nicht

    Hi,
    es läuft bei mir immer noch nicht: ich kann maximal 4 Bilder hochladen (egal ob im ZIP oder offen). Ich könnte Pakete mit 4 Bildern hochladen, allerdings verliert man schnell die Übersicht und irgendwie ist der Sinn der "einfachen Anwendung" so auch verfehlt... Ich habe noch keine Lösung.

    Trotz geänderter php.ini in jedem Verzeichnis.
     
  16. samsonb

    samsonb Active Member

    Registriert seit:
    12. Februar 2007
    Beiträge:
    31
    Zustimmungen:
    0
    bei mir ist es wie schon beschrieben ähnlich
    habe früher schon gallerien mit über 9 mb importiert
    komme nun nur noch bis 1,3mb dann bricht er ab.
    gruß
     
  17. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Beim Upload spielt auch noch der Parameter upload_max_filesize eine Rolle, der steht bei Strato auf 2MB, dürfte also mit großen Bildern oder ZIP-Paketen ein Problem werden. Außerdem wirkt sich auch noch post_max_size (default ist hier 8MB) aus, gewissermaßen als absolute Obergrenze.

    Ich weiß jetzt aber nicht, ob man die Wert auch einfach so per php.ini hochsetzen kann.

    Gruß
    Ingo
     
  18. Iunius

    Iunius Well-Known Member

    Registriert seit:
    29. September 2006
    Beiträge:
    245
    Zustimmungen:
    1
    Können schon,
    jedoch ehrlich gesagt ist es doch recht effizienter bei Strato via FTP zu arbeiten.

    Folgendes Beispiel=>
    php.ini:
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Ergebnis: Dateien welche sich im MB aufhielten wurde nicht erfolgreich hochgeladen.
    Fazit: Ich arbeite lieber via FTP, da weiß ich was ankommt. ;)

    Gruß
     
  19. samsonb

    samsonb Active Member

    Registriert seit:
    12. Februar 2007
    Beiträge:
    31
    Zustimmungen:
    0
    Ja das bringt bei mir leider auch nichts, bin bei hostlocoo und da gibt es von anfang an 32m speicher.
    die anderen werte sind auch gleich oder größer. also ohne das ich etwas verändert habe.
    die wpconfig habe ich auch schon bearbeitet.
    habe auch schon auf 64 bit umgestellt
    aber ich habe immer noch das gleiche problem.
    jedesmal beim importieren von Bildern bei mygallery kommt diese schöne fehlermeldung
     
  20. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    So, ich habe nochmal ein wenig rumprobiert. Es ist tatsächlich so, daß die Dateigröße beim Upload auf 4096000 Bytes "gedeckelt" wird, auch wenn man größere Werte für upload_max_filesize und post_max_size verwendet. Warum das so ist, weiß ich nicht. Vielleicht werden die PHP-Einstellungen noch von irgendwelchen Apache-Einstellungen "überstimmt".
    Mit der folgenden php.ini schafft man aber wenigstens die 4096000 Bytes, es darf aber kein Byte mehr sein:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Die Zeitwerte sollten auch etwas höher, so wie angegeben, angesetzt werden, denn bei meiner dürftigen 384er DSL-Uploadgeschwindigkeit dauern die knapp 4MB ja schon fast 2 Minuten.

    Und ganz wichtig, die php.ini muß immer in dem Verzeichnis stehen, wo sie wirken soll. Bei Verwendung der WP-internen Uploadfunktion also in /wp-admin/, für Plugins gegebenfalls auch im Pluginverzeichnis.

    Gruß
    Ingo
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden