1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

problem beim uploaden von bildern

Dieses Thema im Forum "Allgemeines" wurde erstellt von peapo, 2. Januar 2006.

  1. peapo

    peapo Active Member

    Registriert seit:
    4. Oktober 2005
    Beiträge:
    26
    Zustimmungen:
    0
    Hallo !

    Wenn ich zu einem Post ein Bild uploaden möchte , dann wird mir folgendes mitgeteilt:

    Warning: move_uploaded_file(): SAFE MODE Restriction in effect. The script whose uid is 636 is not allowed to access /srv/www/web1/html/gabberbox.website/wp-content/uploads/2006/01 owned by uid 30 in /srv/www/web1/html/gabberbox.website/wp-admin/admin-functions.php on line 1757
    Die hochgeladene Datei konnte nicht nach verschoben werden.

    Ich benutze WP2
    Hat jemand eine Idee wie ich das Problem lösen kann ?

    edit: ich habe mal einen screenshot gemacht!
    http://img502.imageshack.us/img502/3686/hier9oq.jpg



    // edit2: problem gelöst
     
    #1 peapo, 2. Januar 2006
    Zuletzt bearbeitet: 4. Januar 2006
  2. asti

    asti Member

    Registriert seit:
    18. Dezember 2005
    Beiträge:
    10
    Zustimmungen:
    0
    Wie sieht denn Deine Lösung aus?

    Hallo,

    wie hast Du das denn hinbekommen? Ich habe das selbe Problem, kann den Provider nicht wechseln und wahrscheinlich weigert er sich, Safe Mode off zu stellen.

    Danke im Voraus für eine Antwort!

    asti
     
  3. egen

    egen New Member

    Registriert seit:
    13. Januar 2006
    Beiträge:
    4
    Zustimmungen:
    0
    Ähnliches Problem

    Bei mir funktioniert das uploaden von bildern auch nicht, auch als admin.
    Es kommt folgende Fehlermeldung:move_uploaded_file failed to open stream: Permission denied in /home/osinski/public_html/wp-admin/admin-functions.php on line 1757



    Weiß jemand wo und wie cih die Einstellung zum Beschreiben der Datenbank ändern kann.
    Danke


    Edit schon ok
     
    #3 egen, 13. Januar 2006
    Zuletzt bearbeitet: 13. Januar 2006
  4. alexw

    alexw Member

    Registriert seit:
    14. Januar 2006
    Beiträge:
    6
    Zustimmungen:
    0
    Probleme beim Hochladen von Bildern

    Wenn ich ein Bild uploaden will, bekommeich stets folgende Fehlermeldung (Beispiel): "Unable to create directory /www/htdocs/w0063e37/wp-content/uploads/2006. Is /www/htdocs/w0063e37/wp-content/uploads writable?". Ich verstehe das nicht. Warum sollte das Verzeichnis nicht "writable" sein? Schließlich greife ich doch auch auf andere Ordner zuVielen Dank für Eure Hilfe!
     
  5. ratterobert

    ratterobert Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Januar 2005
    Beiträge:
    1.237
    Zustimmungen:
    0
    kannst du sagen, was es war?


    @alexw: hat der ordner die erforderlichen schreibrechte?
     
  6. alexw

    alexw Member

    Registriert seit:
    14. Januar 2006
    Beiträge:
    6
    Zustimmungen:
    0
    Die Datei, die ich hochladen wollte, ist ein JPG.

    Gruß
     
  7. egen

    egen New Member

    Registriert seit:
    13. Januar 2006
    Beiträge:
    4
    Zustimmungen:
    0
    Lag auch an den Zugriffsrechten
     
  8. sternenlicht

    sternenlicht Well-Known Member

    Registriert seit:
    29. Juni 2005
    Beiträge:
    506
    Zustimmungen:
    0
    wie sieht denn die lösung aus? das safe_mode-dingens hab ich nämlich auch... und es nervt.
    da funktioniert nämlich auch das wp 2.0 interne datenbank-back-up nicht.
     
  9. Lyrasia

    Lyrasia Active Member

    Registriert seit:
    10. Januar 2006
    Beiträge:
    25
    Zustimmungen:
    0
    permisson denied bei upload und weiteres...

    die von WP2 gewünschten Ordner /2006/01 oder im nächsten Monat dann 2006/02 müssen manuell angelegt werden per ftp-zugang.

    dann rechtsklick auf den jeweiligen Ordner, dort im Kontextmenu ganz unten Dateiattribute... klicken, und im Fenster was aufgeht die Benutzerberechtigungen einstellen. ( sie sind nicht auf schreiben können voreingestellt) Ich hab sie auf 777 gesetzt, also alles angeklickt, dann klappt alles.

    Dieses sollte auch das Problem von egen lösen

    lg
    Lyrasia
    (hab die Lösung mal in Anfängersprache geschrieben für entsprechend suchende..)
     
    #9 Lyrasia, 4. Februar 2006
    Zuletzt bearbeitet: 4. Februar 2006
  10. Androlos

    Androlos New Member

    Registriert seit:
    4. November 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Ähnliches Problem

    Da ich zu dem Thema keinen Beitrag im Forum finden konnte hier meine Fehlermeldung:

    Das Verzeichnis /www/htdocs/w0092983/wp-content/uploads/2007/11 kann nicht angelegt werden.
    Ist das übergeordnete Verzeichnis durch den Server beschreibbar?

    Dann habe ich mal dieses Verzeichnis angelegt und alle Schreibrechte gegeben (Attributziffer 777), klappte trotzdem nicht. Wäre nett wenn ich Hilfebekommen könnte

    Wenn ich den Ordner manuell Anlege und alle Schreibrechte gebe kommt folgende Meldung:
    Die hochgeladene Datei konnte nicht nach /www/htdocs/w0092983/wp-content/uploads/2007/11 verschoben werden.
     
    #10 Androlos, 4. November 2007
    Zuletzt bearbeitet: 4. November 2007
  11. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Deaktiviere in den Einstellungen die Organisation nach Jahres- und Monatsbasierten Ordnern.
     
  12. Androlos

    Androlos New Member

    Registriert seit:
    4. November 2007
    Beiträge:
    3
    Zustimmungen:
    0
    Ah, stimmt es geht! Vielen Dank für die sehr schnelle Antwort!
     
  13. wp-noop

    wp-noop New Member

    Registriert seit:
    6. November 2007
    Beiträge:
    1
    Zustimmungen:
    0
    Hi,
    benutze WP 2.3 und habe das gleiche Problem wie Lyrasia und Androlos (= kann keine Bilder uploaden.)
    WP sagt mir: "Das Verzeichnis /www/htdocs/w0092b83/wp-content/uploads/2007/11 kann nicht angelegt werden. Ist das übergeordnete Verzeichnis durch den Server beschreibbar?"
    Packe es leider nicht, per ftp die Schreibberechtigung hochzustellen. Habe jetzt in filezilla im WP-Ordner ein Verzeichnis 2007/11 angelegt, aber da geht kein Fenster auf, in dem ich die Schreibberechtigung einstellen kann - was mache ich falsch? :confused:
     
  14. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Bitte lese doch einfach was in den FAQ steht oder hier im Thread...

    Ansonsten kann man auch in FileZilla CHMOD einstellen.
     
  15. schmedu

    schmedu Member

    Registriert seit:
    3. Dezember 2007
    Beiträge:
    5
    Zustimmungen:
    0
    Wie kann ich Bilder per FTP uploaden?

    Im Browser kann ich Bilder problemlos uploaden.
    Die Bilder werden im Editor angezeigt, alles in Ordnung.
    Diese Bilder werden im Ordner wp-content/uploads/ gespeichert.
    Immer "bild.jpg" und "bild.thumbnail.jpg".

    Verschiebe ich jetzt aber direkt ein Bild mittels FTP Programm
    in den wp-content/uploads/ Ordner, werden diese nicht erkannt!
    Geht das überhaupt, oder was mache ich falsch?

    Bei mehreren Bilder alle über den Browser zu laden ist mühsam!

    MfG
     
  16. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Bilder einfach per FTP hochladen geht in so fern nicht, dass WP nicht weiß, dass es diese Bilder gibt. Denn bei jedem Bildupload über WP wird ein Eintrag in der Datenbank angelegt...
    Du könntest dir ja ein anderes Plugin zur Bildorganisation besorgen. Manche von denen dürften kein Problem damit haben, Bilder zu verarbeiten die über FTP hochgeladen wurden.
     
  17. schmedu

    schmedu Member

    Registriert seit:
    3. Dezember 2007
    Beiträge:
    5
    Zustimmungen:
    0
    danke für die antwort.

    kennst du phpwcms?
    hat zwar nichts mit wordpress zu tun,
    aber da konnte man die bilder per ftp in einen ordner laden,
    und nach erfolgtem upload für das cms system sichtbar machen.

    so etwas ähnliches habe ich mir bei wordpress auch erhofft.
    kennst du ein plugin, welches diese ftp-übernahme unterstützt?
     
  18. mybodyactive

    mybodyactive Active Member

    Registriert seit:
    14. März 2008
    Beiträge:
    32
    Zustimmungen:
    0
    ic aknn auch keine bilder hochladen. Keine neue Seite erstellen ohne diese Fehlermeldung zu erhalten

    Fatal error: Cannot use object of type WP_Error as array in /is/htdocs/wp1012625_JFO7LL26A0/wordpress/wp-includes/taxonomy.php on line 1014

    Ich bin echt langsam am verzweilen. brauche dringend hilfe.
     
  19. HDD-Benny

    HDD-Benny New Member

    Registriert seit:
    17. Juli 2008
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo Forum,

    ich reihe mich mit meinem Problem hier gerne mit ein. Auch bei mir funktioniert der Upload von Bildern nicht und leider haben die wirklich guten Tipps bei mir keine Besserung gebracht.

    Die Schreibrechte sind angepasst und egal ob in WP die Option "Uploads nach Jahren/Monaten sortieren" aktiviert oder deaktiviert lasse, es ist keine Besserung in Sicht. Sofern ich den Monatsordner manuell via FTP-Zugang einrichte, kommt folgende Meldung:

    Die hochgeladene Datei konnte nicht nach <code>/..../meldungen/images/2008/08</code> verschoben werden.

    Soll WP einen noch nicht vorhandenen Monatsordner erstellen, klafft diese Meldung auf dem Monitor:

    Das Verzeichnis /...../meldungen/images/2008/08 konnte nicht erstellt werden. Ist das darüberliegende Verzeichnis für den Webserver schreibbar?

    Der Hammer ist nur folgender: Der Save-Mode ist auf "meinem" Server nicht mal aktiviert! Getestet habe ich das mit diesem kleinen Script.

    Hat zufällig jemand eine Idee (außer Provider wechseln)?
    Lieben Gruß
    Benny
     
  20. Monika

    Monika Well-Known Member
    Ehrenmitglied

    Registriert seit:
    4. Juni 2005
    Beiträge:
    14.126
    Zustimmungen:
    1
    mag verrückt klingen..

    alle Plugins deaktiveren,

    ausloggen als Admin
    Browsercache leeren- total-

    einloggen probieren...

    gehts -ist ein Plugin Schuld-
    gehts net---

    haben die Ordner eventuell nicht die richtigen Rechte...
    oft vererben die Ordner nicht-wieso ...??
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden