1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Problem mit Permalinks

Dieses Thema im Forum "Konfiguration" wurde erstellt von BettinaW, 27. Mai 2013.

  1. BettinaW

    BettinaW Member

    Registriert seit:
    27. Mai 2013
    Beiträge:
    16
    Zustimmungen:
    0
    Hallo,

    ich habe ein Problem bei meiner wordpress Konfiguration. Ich habe eben die Permalink Einstellungen verändert und dann (wie schon einige Male vorher) folgende Fehlermeldung bekommen:

    Forbidden

    You don't have permission to access /wp-admin/options-permalink.php on this server.
    [HR][/HR]Apache/2.2.16 (Debian) Server at global-elite-team.de Port 80

    Wer kann mir einen Tipp geben?
    Vielen Dank schon mal...

    BettinaW
     
  2. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Poste mal den Inhalt deiner .htaccess.
     
  3. BettinaW

    BettinaW Member

    Registriert seit:
    27. Mai 2013
    Beiträge:
    16
    Zustimmungen:
    0
    Habe keine per FTP gefunden. Wo ist die oder muss ich eine anlegen?
     
  4. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Was genau hast du verändert? Hier scheint ein Rechteproblem vorzuliegen.
     
  5. BettinaW

    BettinaW Member

    Registriert seit:
    27. Mai 2013
    Beiträge:
    16
    Zustimmungen:
    0
    Welche Rechte muss ich denn geben? Ich habe die Seite jetzt so oft schon neu hochgeladen, weil ich dieses Problem schon einige Male hatte, dass ich gar nicht mehr weiß, was ich wann verändert habe. Vielleicht sollte ich sie nochmal mit dem download file von wp hochladen?
     
  6. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    755 für Verzeichnisse und 644 für Dateien sollte erst mal ok sein.
     
  7. BettinaW

    BettinaW Member

    Registriert seit:
    27. Mai 2013
    Beiträge:
    16
    Zustimmungen:
    0
    Also, habe jetzt mal die htaccess als Textdatei hochgeladen mit der Berechtigung 644. Nachdem ich die Datei umbenannt habe in .htaccess und die Berechtigungen auf 777 eingestellt habe, ist die Datei weg. Jetzt habe ich 755 probiert, die Datei ist noch da. Aber wenn ich die Permalinks verändern will, bekomme ich sofort die Fehlermeldung wieder. :(
     
  8. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Stelle mal die Permalinks auf Standard. Läuft dann Wordpress problemlos?
     
  9. BettinaW

    BettinaW Member

    Registriert seit:
    27. Mai 2013
    Beiträge:
    16
    Zustimmungen:
    0
    Nein, dann ist die Seite auch sofort weg :(

    Habe dir eine PN gesendet.
     
    #9 BettinaW, 27. Mai 2013
    Zuletzt bearbeitet: 27. Mai 2013
  10. formateins

    formateins Gast

    Die .htaccess ist nicht weg - Du musst in Deinem FTP-Programm die versteckten Dateien anzeigen lassen. Alternativ WinSCP nutzen, das zeigt sie auch so an. ;)

    Du kannst die Datei lokal leer erstellen und per FTP hochladen. Wenn Dein Server/Webspace sauber konfiguriert ist, musst Du die Dateirechte (644 oder 444) nicht mehr anpassen. Wenn WP beim Aktualisieren der Permalink-Struktur rummeckert, ändere die Dateiberechtigungen auf 755. Passt das auch nicht > 777 und wenn fertig auf 644.

    --

    Überprüfe, ob WP bzw. PHP über genügend Speicher verfügt. Das kannst Du mit einem Plugin machen: http://wordpress.org/plugins/wp-memory-usage/

    Alternativ in der wp-config.php die Option WP_DEBUG auf "true" setzen. Editiere eine Page oder einen Post und scroll ganz runter - die Fehlermeldung taucht am Ende der Seite auf (memory allocation error/exhaust). Tritt das auf deaktiviere zum Testen alle Plugins und setz die Permalink-Struktur auf Standard zurück. Bei einem Webspace kontaktiere Deinen Provider zu diesem Thema (in der Regel funktionieren die ini_set-Geschichten in der .htaccess nicht) und bitte ihn, das memory_limit auf mind. 96M - besser jedoch 128M zu setzen. Schau auch in Deinem Kundenbereich nach, ob Du dort ggf. eine solche Option findest.

    Wenn Du einen vServer/Dedicated hast, kannst Du das in der Admin-Oberfläche bei den Domaineinstellungen vornehmen.

    --

    Wenn Du twentytwelve noch installiert hast, wechsle auf dieses Theme. Prüfe, ob damit die Permalinks funktionieren. Wenn ja, siehe Speicherproblem.

    --

    Als letzte Option stell bitte die Standard-Permalinks ein. Anschließend öffne die functions.php (oder äq.) Deines Themes und füge am Ende in eine neue Zeile (vor dem ?> ) flush_rewrite_rules('false'); ein. Ändere dann die Permalink-Struktur wie gewünscht. Die Links sollten dann funktionieren. Wenn nicht, siehe Speicherproblem. Wichtig: unbedingt im Produktivbetrieb wieder rausnehmen. Wenn es funktioniert, poste ich Dir gerne eine notwendige Funktion, damit das Dauerhaft eingesetzt werden kann (Theme Activation-Hook).

    Bitte beachten:
    Das Erstellen einer Kategorie (oder generell eines Slugs) führt zum Flush der Regeln! Bestimmte Plugins können das auch wieder auf 'true' setzen.

    Viel Erfolg.
     
  11. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.891
    Zustimmungen:
    15
    Weißt Du überhaupt, was die 7 bei den Rechten für Dateien bedeutet? Die Datei ist lesbar, beschreibbar und ausführbar. Die .htaccess-Datei sollte bzw. darf mit Sicherheit nicht ausführbar sein. Wenn man Schreibrechte für alle auf eine normale Datei setzen will, dann mit 666.

    644 reicht meistens dann, wenn PHP als CGI im Kontexte des Benutzers läuft, wie z.B. bei Strato und 1&1. Läuft PHP als Apache-Modul im Kontext des Webservers, ist hingegen meist 666 erforderlich, wie z.B. bei All-Inkl.

    Gruß
    Ingo
     
  12. formateins

    formateins Gast

    Es glänzt, es glänzt so schön... Bravo, TOP-Aufklärung.

    Keinen Gruß,
    Jörg
     
  13. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.891
    Zustimmungen:
    15
    Danke für die lobenden Worte, aber warum "Keinen Gruß"?

    Gruß
    Ingo
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden