1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 5.4 Redirect funktioniert nicht richtig

Dieses Thema im Forum "Konfiguration" wurde erstellt von Huby, 20. November 2020 um 12:50 Uhr.

Schlagworte:
  1. Huby

    Huby Member

    Registriert seit:
    1. September 2016
    Beiträge:
    10
    Zustimmungen:
    0
    Ich habe einen Redirect (sowohl für http zu https wie auch http://www zu http://
    Leider wirft wir der Redirect-Prüfer eine FEhlermeldung raus.
    In der httaccess steht
    #<IfModule mod_rewrite.c>
    #RewriteEngine On
    #RewriteCond %{HTTPS} !=on
    #RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    #</IfModule>

    im A-Record habe ich www auf die IP weitergeleitet.
    VIelleicht hat jemand eine Idee wo mein Problem liegt. Trotz vielem googeln komme ich nicht weiter.

    [​IMG]
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    7.900
    Zustimmungen:
    842
    Der gepostete Auszug aus der .htaccess ist auskommentiert und damit nicht aktiv.
     
    Huby gefällt das.
  3. Huby

    Huby Member

    Registriert seit:
    1. September 2016
    Beiträge:
    10
    Zustimmungen:
    0
    Danke für deine schnelle Reaktion, das war natürlich ein Fail... Leider ist es auch ohne das # das gleiche Problem. (als der Screenshot oben entstand war es auch ohne # in der htaccess).
     
  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    7.900
    Zustimmungen:
    842
    Frage mal bei der Person nach, die diesen Redirect für Dich erstellt hat, die aktuelle Regel kommt nur zum Einsatz, wenn kein https verwendet wird und beachtet nichts bzgl. www
     
  5. Huby

    Huby Member

    Registriert seit:
    1. September 2016
    Beiträge:
    10
    Zustimmungen:
    0
    Oh man.... Ich habe meine Datei immer ins falsche Verzeichnis geladen... so ein dummer Fehler... Danke trotzdem.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden