1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

seit php Umstellung geht die Website nicht mehr

Dieses Thema im Forum "Konfiguration" wurde erstellt von shravan, 8. Oktober 2012.

  1. shravan

    shravan Active Member

    Registriert seit:
    17. November 2010
    Beiträge:
    25
    Zustimmungen:
    0
    Hallo zusammen,

    unser Provider hat gestern die PHP Version von 5.2. auf 5.3. umgestellt, seit dem läuft unsere WI Installation nicht mehr, bzw. ist nicht mehr erreichbar. Lt prov. kann ich zwar in der htaccess auch wieder auf die 5.2 umstellen, aber das hilft gar nicht. Irgendwie versucht mein browser ständig eine Datei herunter zu laden. habt Ihr vielleicht eine rettende Idee? ;)

    www.ev-kirche-ginsheim.de

    Vielen Dank.
    Stefan
     
  2. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    10.451
    Zustimmungen:
    85
    Schau mal bitte über FTP ob Deine Ordner noch mit den Rechten 755 und die Dateien mit 644 laufen.
     
  3. shravan

    shravan Active Member

    Registriert seit:
    17. November 2010
    Beiträge:
    25
    Zustimmungen:
    0
    vielen dank für den Tip und ja, das ist noch so. Ich habe jetzt mal das errorlog aktiviert und bekomme laufend den Fehler geschrieben:
    [Mon Oct 08 08:43:19 2012] [error] [client 5.9.25.72] Premature end of script headers: php53-fcgi-starter
    [Mon Oct 08 09:33:41 2012] [warn] [client 5.9.25.69] mod_fcgid: read data timeout in 40 seconds

    habe das mal an den Serversupport gemailt, denke ja, dass es ein Problem vom Hoster ist, da es unmittelbar nach der Umstellung aufgetreten ist.
     
  4. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.962
    Zustimmungen:
    5
    Ja, meiner Meinung nach stimmen die Rechte nicht. Welche Wordpress Version ist installiert?
     
    #4 Hille, 8. Oktober 2012
    Zuletzt bearbeitet: 8. Oktober 2012
  5. shravan

    shravan Active Member

    Registriert seit:
    17. November 2010
    Beiträge:
    25
    Zustimmungen:
    0
    Es ist die aktuellste installiert, 3.4.2. Ich selber habe keinerlei Änderungen vorgenommen,nur die PHP Version wurde vom Hoster aktualisiert.
     
  6. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    10.451
    Zustimmungen:
    85
    Ich denke irgendwas wurde am Timeout geändert. Warte mal die Rückmeldung ab.
     
  7. shravan

    shravan Active Member

    Registriert seit:
    17. November 2010
    Beiträge:
    25
    Zustimmungen:
    0
    vom Hoster habe ich folgende Info bekommen:

    Als erstes wechseln Sie bitte zurück auf php-5.2.

    Die .htaccess muss folgende Zeile enthalten:
    AddHandler php52-fastcgi .php

    Danach kontrollieren Sie bitte Ihre Scripte auf php-5.3 Kompatibilität.

    -----------------------------------------------------------------------------------------------------


    Da ich eine fast identische installation auf einem anderen server habe und keine probleme bei höherer PHP Version denke ich nicht dass es an den Scripten liegen kann.

    Nachdem ich in der htaccess den Eintrag AddHandler php52-fastcgi .php ergänzt habe, wird eine 404 ausgegeben:
    The requested URL /fastcgiphp/php52-fcgi-starter/index.php was not found on this server.

    .....
     
  8. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.962
    Zustimmungen:
    5
    Poste mal deine .htaccess. Hast du denn mal die Rechte überprüft ob da wirklich alles i.O. ist?
     
  9. shravan

    shravan Active Member

    Registriert seit:
    17. November 2010
    Beiträge:
    25
    Zustimmungen:
    0
    so schaut meine .htaccess aus:

    AddHandler php52-fastcgi .php
    <IfModule mod_php.c>
    php_value suhosin.post.max_vars 2000
    php_value suhosin.request.max_vars 1000
    php_value suhosin.get.max_vars 1000
    </IfModule>


    Redirect /dokumente http://www.ev-kirche-ginsheim.de/wp-login.php?redirect_to=http://www.ev-kirche-ginsheim.de/download


    # BEGIN Primary Feedburner
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTP_USER_AGENT} !^(FeedBurner|FeedValidator) [NC]
    RewriteRule ^feed/?([_0-9a-z-]+)?/?$ http://feeds.feedburner.com/EvangelischeKircheGinsheim [R=301,NC,L]


    # END Primary Feedburner


    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>


    # END WordPress

    Was die Rechte anbelangt, habe ich ja nichts geändert, habe aber geprüft, dass die Ordner im Root auf 755 und die Dateien auf 644 gesetzt sind.
     
  10. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    10.451
    Zustimmungen:
    85
    Hast Du hier nicht ein Leerzeichen zuviel drin, vor dem .php?
    AddHandler php52-fastcgi .php

     
  11. shravan

    shravan Active Member

    Registriert seit:
    17. November 2010
    Beiträge:
    25
    Zustimmungen:
    0
    ja du hast recht, sorry, das hatte ich aber auch schon rausgenommen, nun auch wieder und dann versucht der browser eine WP datei downzuladen statt die Website zu öffnen. Doofe Sache.
     
  12. shravan

    shravan Active Member

    Registriert seit:
    17. November 2010
    Beiträge:
    25
    Zustimmungen:
    0
    Hallo,

    keiner hat was gemacht, aber die Seite geht nun wieder^^ na was solls, hauptsache es ist wieder ok ;)
    Vielen Dank für die Hilfestellungen.

    Viele Grüsse,
    Stefan
     
  13. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    10.451
    Zustimmungen:
    85
    Vielleicht hat Dein Hoster gemerkt, dass er was falsch konfiguriert hatte. Schön dass es jetzt wieder geht.