1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.4 Seite kann nicht mehr aufgerufen werden

Dieses Thema im Forum "Konfiguration" wurde erstellt von kinimod71, 5. Oktober 2016.

  1. kinimod71

    kinimod71 Member

    Registriert seit:
    5. Oktober 2016
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo, ich bin neu hier und hoffe, dass mir geholfen werden kann.

    Die Seite neue-ziegelei.de ist mit WordPress erstellt worden und bei Strato gehostet.

    Am gestrigen Tage habe ich noch inhaltliche Anpassungen vorgenommen und die Seite funktionierte einwandfrei. Heute kommt folgende Fehlermeldung:Die Seite neue-ziegelei.de funktioniert nicht

    neue-ziegelei.de kann diese Anfrage momentan nicht verarbeiten.
    HTTP ERROR 500




    Ich komme auch nicht mehr auf die Anmeldeseite.

    Nach dem Studium diverser Threads habe ich per ftp im Ordner wp-content/plugins alle Plugin-Ordner umbenannt. Leider hat dies nicht geholfen.

    Das Einspielen eines 3 Tage alten Backups über Strato hat ebenfalls nicht funktioniert.

    Was kann ich noch tun ?
     
  2. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.449
    Zustimmungen:
    98
    Hi,

    melde dich mal an Strato. Ein Error 500 ist ein Serverfehler.

    Vielleicht wird der Fehler auch durch eine falsche .htaccess Datei erzeugt. Am einfachsten ist es, wenn man nach den error_logs schaut.
     
  3. kinimod71

    kinimod71 Member

    Registriert seit:
    5. Oktober 2016
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo, schon mal danke für die Antwort.
    wie das so ist wirft deine Antwort einige neue Fragen auf.
    a) wie sollte eine "idiotensichere" .htaccess Datei aussehen, dass sie auf jeden Fall funktioniert
    b) wo finde ich die error_logs?

    Bei Strato hat man mich auf eine evtl. falsche PHP-Version hingewiesen. Wie kann ich jetzt noch überprüfen, welche php-Version ich bei meinem WP nutze.

    Weiterhin hilft vielleicht noch folgender Hinweis:

    Ich hatte die Seite zuerst unter etw-neheim.de (auch bei Strato) erstellt. Dann habe ich unter neue-ziegelei.de eine externe Umleitung (Proxy) auf etw-neheim.de erstellt.

    Hier ist eine interne Umleitung auf das Wordpressverzeichns eingerichtet.

    Hat es eigentlich etwas zu sagen, dass WordPress den Zusatz "Secure Mode " hat?

    Ich weiß, das sind ganz schön viele Fragen, aber ich bin in dieser Angelegenheit ganz schön dumm.

    Vorab schon mal an alle, die Ihren Hirnschmalz ;) für dieses Problem opfern, ein herzliches Dankeschön.
     
  4. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.449
    Zustimmungen:
    98
  5. kinimod71

    kinimod71 Member

    Registriert seit:
    5. Oktober 2016
    Beiträge:
    7
    Zustimmungen:
    0
    Also die PHP-Version ist auch 5.6

    Der Errorlog beginnt mit folgenden Zeilen:

    04.10.2016 14:50:38 etw-neheim.de [client 92.72.88.0] PHP Warning: Unknown: failed to open stream: No such file or directory in Unknown on line 0

    04.10.2016 14:50:38 etw-neheim.de [client 92.72.88.0] PHP Fatal error: Unknown: Failed opening required '/mnt/webw/d1/19/57059519/htdocs/WordPress_SecureMode_01/wordfence-waf.php' (include_path='.:/opt/RZphp56/includes') in Unknown on line 0


    Kurz davor war folgender Zugriff zu verzeichnen:

    etw-neheim.de anon-192-168-49-168.d0m.de - - [04/Oct/2016:14:46:18 +0200] "POST /wp-cron.php?doing_wp_cron=1475585178.7048161029815673828125 HTTP/1.1" 200 - "http://neue-ziegelei.de/wp-cron.php?doing_wp_cron=1475585178.7048161029815673828125" "WordPress/4.6.1; http://neue-ziegelei.de"

    Hilft das etwas?


     
  6. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.449
    Zustimmungen:
    98
    Zeig mal bitte deine .htaccess
     
  7. kinimod71

    kinimod71 Member

    Registriert seit:
    5. Oktober 2016
    Beiträge:
    7
    Zustimmungen:
    0
    Bitteschön:


    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>


    # END WordPress


    # Wordfence WAF


    <Files ".user.ini">
    <IfModule mod_authz_core.c>
    Require all denied
    </IfModule>
    <IfModule !mod_authz_core.c>
    Order deny,allow
    Deny from all
    </IfModule>
    </Files>


    # END Wordfence WAF

    Da ich die Plugins alle umbenannt habe, um sie zu deaktivieren, hab ich die .htaccess auch ohne den Wordfence-Teil ausprobiert. Funktioniert leider beides nicht.
     
  8. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.449
    Zustimmungen:
    98
    Gibt es eine .user.ini ?
     
  9. kinimod71

    kinimod71 Member

    Registriert seit:
    5. Oktober 2016
    Beiträge:
    7
    Zustimmungen:
    0
    Yep, die gibt es.

    ; Wordfence WAF

    auto_prepend_file = '/mnt/webw/d1/19/57059519/htdocs/WordPress_SecureMode_01/wordfence-waf.php'
    ; END Wordfence WAF

    Die wordfence-waf.php lautet:

    <?php
    // Before removing this file, please verify the PHP ini setting `auto_prepend_file` does not point to this.


    if (file_exists('/mnt/webw/d1/19/57059519/htdocs/WordPress_SecureMode_01/wp-content/plugins/wordfence/waf/bootstrap.php')) {
    define("WFWAF_LOG_PATH", '/mnt/webw/d1/19/57059519/htdocs/WordPress_SecureMode_01/wp-content/wflogs/');
    include_once '/mnt/webw/d1/19/57059519/htdocs/WordPress_SecureMode_01/wp-content/plugins/wordfence/waf/bootstrap.php';
    }
    ?>

    Den Ordner wflogs gibt es.

    Die Bootstrap.php gibt es auch. Benötigst du da auch den Quelltext?
     
  10. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.449
    Zustimmungen:
    98
    sicher die user.ini und entferne sie dann aus deinem webspace.
     
  11. kinimod71

    kinimod71 Member

    Registriert seit:
    5. Oktober 2016
    Beiträge:
    7
    Zustimmungen:
    0
    SUPER es funktioniert!
    DANKE!
    Kann ich jetzt die Plugin-Verzeichnisse einfach wieder umbenennen, damit alles wie vorher funktioniert?

    Worauf muss ich achten bzw. was bewirkt dieses user.ini?
     
  12. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.449
    Zustimmungen:
    98
    Das mit den Plugins, JA.

    Das mit dieser user.ini, muss du deinen Webhoster fragen.
     
  13. kinimod71

    kinimod71 Member

    Registriert seit:
    5. Oktober 2016
    Beiträge:
    7
    Zustimmungen:
    0
    OK, nochmal vielen Dank.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden