1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Shop kaputt?

Dieses Thema im Forum "WooCommerce" wurde erstellt von Martin-R, 13. April 2017.

Schlagworte:
  1. Martin-R

    Martin-R Member

    Registriert seit:
    15. November 2016
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo,

    ich habe einen Mini Woocommerce Shop aufgebaut und alles funktionierte soweit: http://www.topcar.de/shop/

    Wie ihr seht haut da was nicht hin. In der Zeile 3829 steht nur das: trigger_error( sprintf( __('%1$s is <strong>deprecated</strong> since version %2$s! Use %3$s instead.'), $function, $version, $replacement ) );

    Was kann ich damit anfangen? Soll ich da überhaupt etwas ändern? Google spuckt zu dem Spruch leider nichts aus. Alle Updates sind gemacht.
    Hat jemand eine Idee für eine Lösung?

    viele Grüße,
    Martin
     
  2. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    5.304
    Zustimmungen:
    174
    eigentlich funktionierte nach der Fehlerausgabe ein nichts wirklich richtig...

    Damit erzeugt WooCommerce die "hilfreichen" Hinweise:


    <b>Notice</b>: woocommerce_get_page_id ist seit Version 3.0 <strong>veraltet</strong>! Benutzen Sie stattdessen wc_get_page_id. in <b>~/wp-includes/functions.php</b> on line <b>3829</b><br />

    Deine Theme passt leider nicht mehr zu deiner WooCommerce Version. Wenn dir dein Theme Autor (Entwickler fällt mir jetzt nicht ein) kein Update erstellt hat - musst du in dem theme
    woocommerce_get_page_id durch wc_get_page_id ändern - vermutlich sind weitere Änderungen nötig.
     
  3. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.332
    Zustimmungen:
    324
    Das ist nicht korrekt. Die Themeversion ist NICHT aktuell (4.0.2 anstatt 4.0.5), ebenso die WooCommerce Version (3.0.2 statt 3.0.3). Mit Enfold hast Du auch Support gekauft, entsprechend solltest Du auch zuerst in das Forum auf kriesi.at sehen. Dort gibt es bereits etliche Threads zum Theme. Die Warnmeldungen schaltet man auf einem Produktionssystem durch Deaktivieren des DEBUG Modus in der wp-config.php ab.
     
  4. Martin-R

    Martin-R Member

    Registriert seit:
    15. November 2016
    Beiträge:
    8
    Zustimmungen:
    0
    Or ihr seit gut, stimmt, das Update des Themes war nicht gemacht und hatte das Problem verursacht. Ich hatte dort den API Key nicht eingegeben und so hat es mir keine Updates angezeigt. Vielen vielen Dank, jetzt geht wieder alles! Super!!!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden