1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Sprachdatei für 2.9.1 zum testen

Dieses Thema im Forum "Sprachdatei" wurde erstellt von Olaf, 30. Dezember 2009.

  1. Olaf

    Olaf WPDE-Team
    Mitarbeiter

    Registriert seit:
    3. September 2004
    Beiträge:
    2.737
    Zustimmungen:
    29
    Hallo zusammen,

    hier die aktuellen Sprachdateien zum testen - basierend auf 2.9.1 RC1:

    --> Du
    --> Sie

    Ich hoffe alle gemeldeten Fehler korrigiert zu haben, desweiteren sind gegenüber 2.9 ca. 50 neue Zeichenketten hinzu gekommen. Verbesserungsvorschläge bitte wieder in diesem Forum melden.

    BG
     
  2. gregma

    gregma Active Member

    Registriert seit:
    22. Juli 2008
    Beiträge:
    29
    Zustimmungen:
    0
    Jetzt habe ich "Approved" Kommentare im Dashboard...?!
    Und beim Artikel schreiben wird mir bei der URL "Get Shortlink" angezeigt...
     
  3. -ivan

    -ivan Well-Known Member

    Registriert seit:
    7. Dezember 2008
    Beiträge:
    495
    Zustimmungen:
    0
    #3 -ivan, 31. Dezember 2009
    Zuletzt bearbeitet: 1. Januar 2010
  4. tin68

    tin68 Well-Known Member

    Registriert seit:
    8. Januar 2006
    Beiträge:
    94
    Zustimmungen:
    0
    In der Du-Version sind die folgenden Zeilen immer noch nicht übersetzt resp. mit den länderspezifischen Werten gefüllt:

    Ab Zeile 3773:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    In der Sie-Version ist es gemacht, wobei des Tausender-Trennzeichen "Komma" für die Schweiz so nicht richtig ist.

    Neben der de_DE.mo müsste es halt dann auch noch eine de_CH.mo Sprachdatei geben.
     
    #4 tin68, 31. Dezember 2009
    Zuletzt bearbeitet: 31. Dezember 2009
  5. tin68

    tin68 Well-Known Member

    Registriert seit:
    8. Januar 2006
    Beiträge:
    94
    Zustimmungen:
    0
    Ersteres kann ich bestätigen - zweites Problem nicht resp. ich weiss nicht genau, wo du meinst.
     
  6. Olaf

    Olaf WPDE-Team
    Mitarbeiter

    Registriert seit:
    3. September 2004
    Beiträge:
    2.737
    Zustimmungen:
    29
    Die Shortlinks sind ein Feature von WordPress.com und werden durch das Plugin "WordPress.com Stats" aktiviert, das Plugin wird nicht von der Sprachdatei übersetzt.


    Nach Recherchen haben wir jetzt die Anwort gefunden. Die entsprechende Stelle findet sich in Zeile 263 der wp-admin/includes/dashboard.php :

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Die offizielle pot bezieht sich (warum auch immer) auf die 3.0-alpha, dort wurde die entsprechende Stelle von _nc auf _nx gesetzt:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    ...zurückgehend auf das folgende Ticket: http://core.trac.wordpress.org/ticket/11404

    In der aktuellen 2.9.1 SVN-Version wird weiterhin _nc verwendet, die offizielle pot verwendet _nx - der Fehler besteht dann also darin, dass die Entwickler die offizielle pot mit der 3.0 Entwicklerversion erstellen.

    Eine Lösung wäre jetzt, dass wir die pot selber erstellen, aber wenn die Entwickler was an den Keywords ändern und wir das nicht mitbekommen haben wir uU ein Problem. Deshalb verwenden wir immer die offizielle pot. Ich werde dem Nikolay die Problematik die Tage mal mitteilen.

    ...gnaargh! Genau das war mal ein breit diskutiertes Thema: "Qualität und Ansprüche an die deutschen Sprachdateien" da ich die Sprachdatei jetzt erst übernommen habe wusste ich nicht, dass das in der Du-Version nicht richtig übersetzt wurde. Ich habs jetzt korrigiert.

    Vielen Dank bei der Fehlersuche! Bitte meldet auch weiterhin alles was ihr findet. Die korrigierten Dateien spiele ich gleich hoch.

    BG
     
  7. -ivan

    -ivan Well-Known Member

    Registriert seit:
    7. Dezember 2008
    Beiträge:
    495
    Zustimmungen:
    0
    @Olaf
    Hier noch ein paar Kleinigkeiten ...

    /wp-admin/edit-tags.php?taxonomy=post_tag
    Die Beschreibung wird nicht immer angezeigt. Bei dem ein oder anderen Theme mag sie angezeigt weden.

    /wp-admin/options-writing.php
    Um einen Artikel in WordPress mit einem Desktop-Blogging-Programm zu erstellen, das das Atom Publishing Protocol oder eine XML-RPC-Schnittstelle benutzt, müssen Sie diese Schnittstellen hier aktivieren.

    /wp-admin/edit-comments.php
    Hier erscheint bei mir Submitted on: anstatt Eingereicht am:

    Siehst Du/Ihr den Fehler auch?

    Übrigens hast Du recht, mit diesem Eintrag ist der Fehler behoben.
    Konntest Du schon mit dem Programmierer reden?

    So muss halt am Core etwas geändert werden, was auch nicht gerade super ist.
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  8. Olaf

    Olaf WPDE-Team
    Mitarbeiter

    Registriert seit:
    3. September 2004
    Beiträge:
    2.737
    Zustimmungen:
    29
    Danke für die Korrekturen, ich hab sie eingepflegt und werde demnächst eine korrigierte Version hochladen. Das Approved-Problem ist ja "nur" eins mit der offiziellen pot-Datei, mal schauen wie wir das lösen.
     
  9. -ivan

    -ivan Well-Known Member

    Registriert seit:
    7. Dezember 2008
    Beiträge:
    495
    Zustimmungen:
    0
    @Olaf
    Danke ....

    Das Approved-Problem ist halt ärgerlich wenn etwas am Core geändert werden muss. Für den Enduser ist es natürlich schwierig, dass Problem nachzuvollziehen. Er downloadet die Zip von Wordpress oder von Euch und installiert sich die Sprachdatei.

    Und sieht am Schluss, dass etwas in Englisch vorhanden ist.

    Gruss Ivan
     
  10. -ivan

    -ivan Well-Known Member

    Registriert seit:
    7. Dezember 2008
    Beiträge:
    495
    Zustimmungen:
    0
    @Olaf
    Bist Du schon ein Schritt weiter?
    Wann kommt denn die neue Version der Sprachdatei?

    Gruss Ivan
     
  11. -ivan

    -ivan Well-Known Member

    Registriert seit:
    7. Dezember 2008
    Beiträge:
    495
    Zustimmungen:
    0
    Hallo zusammen,
    eigentlich ist es schade, dass es wieder so mit den Sprachdateien läuft. Die Personen welche die Sprachdateien übersetzen, haben ja grossartig Besserung gelobt.

    Nun der letzte Post ist vom 5. Januar 2010!

    Leider sind noch nicht alle Fehler gelöst, eine neue Sprachdatei ist noch nicht verfügbar!

    Es wäre schön, wenn Ihr Euch zu dem Thema melden könntet!

    Gruss Ivan
     
    #11 -ivan, 1. Februar 2010
    Zuletzt bearbeitet: 1. Februar 2010
  12. h-u-g-o

    h-u-g-o Well-Known Member

    Registriert seit:
    23. November 2008
    Beiträge:
    704
    Zustimmungen:
    0
    "Approved" ist anscheinend immer noch nicht korrigiert, bei mir taucht's auch bei WordPress 2.9.2 auf. :(
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden