1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Tausend Mal dieselbe Frage....

Dieses Thema im Forum "Konfiguration" wurde erstellt von suquita, 20. Juni 2018.

Schlagworte:
  1. suquita

    suquita Member

    Registriert seit:
    20. Juni 2018
    Beiträge:
    11
    Zustimmungen:
    0
    Hi ihr Lieben,
    ich hab gefühlte tausend Forenbeiträge gelesen, google durchsucht, verschiedene Einstellungen ausprobiert und mir mein Hirn zermatert, aber es funktioniert einfach nicht. :( homepage: albdino.de

    Ich nutze wp twentyseventeen und hätte gerne 2 Beitragsseiten erstellt.
    Ich habe statische Seiten und Kategorien. Die Kategorien (Reise nach Ecuador und Produkttests ) sollen neue Beiträge anzeigen, völlig unabhängig voneinander. Das funktioniert leider nicht.
    Die Permalinks hab ich überprüft, die funktionieren. (also ich kann die seite albdino.de/produkt-tests/decathlon aufrufen, sehe aber auf der Seite /produkt-tests keine beiträge)
    Ich habe akismet, jetpack und fv top level categories installiert.

    Ja ich habe die Beiträge den jeweiligen KAtegorien zugeordnet. Ohne Erfolg....

    Würde mich freuen über Hilfe :)

    Lieben Dank schon mal im Voraus
     
  2. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.448
    Zustimmungen:
    243
    Ich versuch das mal ein bisschen aufzudröseln:

    Die Seite Produkt-Tests ist bei dir als Blogseite eingestellt. Dort erscheinen also alle neuen Beiträge.
    Reise-nach-Ecuador ist eine Seite, dort erscheint kein Beitrag.
    Reise-nach-Ecuador/Blog/ ist eine Kategorie, dort erscheinen nur die Beiträge die dieser Kategorie zugeordnet sind.

    Statische Seiten zeigen keine Beiträge. Nimm dann lieber die Kategorien ins Menü.
     
  3. suquita

    suquita Member

    Registriert seit:
    20. Juni 2018
    Beiträge:
    11
    Zustimmungen:
    0
    Hallo Maxe, ja ich hab mal hin und her getauscht um zu schauen, was sich wie verändert. Reise-nach-Ecuador ist aber eine Kategorie , also bin ich davon ausgegangen, dass Beiträge auch dort auftauchen.
    (Ich Tausch das wieder zurück, aber wenn ich Ecuador als blog Seite einstelle, dann hab ich die Produkttests ja auch darin. Und das will ich nicht....
    War das jetzt so verständlich?

    Ich könnte jeden Beitrag für Produkttests einzeln über das Menü auf der Seite eintragen, aber das muss doch auch anders gehen
     

    Anhänge:

    #3 suquita, 20. Juni 2018
    Zuletzt bearbeitet: 20. Juni 2018
  4. suquita

    suquita Member

    Registriert seit:
    20. Juni 2018
    Beiträge:
    11
    Zustimmungen:
    0
    Hi. Ich hab jetzt den Blog Mal raus genommen und als Beitragsseite Ecuador Reise eingestellt. Da ich eh weniger Produkttests habe, könnte ich damit leben, die Beiträge einzeln im Menü einzufügen (siehe Bild). Aber dennoch sollten diese Produkt-Beiträge NICHT auf der Ecuador Reise Seite erscheinen.
    LG und Dank Sissi
     

    Anhänge:

  5. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.343
    Zustimmungen:
    416
    Keine Blog-Seite dedinieren und dafür beide Kategorien einzeln ins Menü holen.
     
  6. suquita

    suquita Member

    Registriert seit:
    20. Juni 2018
    Beiträge:
    11
    Zustimmungen:
    0
    Danke, aber
    dann erscheinen gar keine Beiträge mehr in keiner der beiden Kategorien....:(
    (Beitragsseite auf "auswählen" gesetzt), Im Menü sind ausser der statischen START Seite nur die Kategorien :(
    SirEctor
     
  7. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.343
    Zustimmungen:
    416
    Du hast die Beiträge aber den richtigen Kategorien zugeordnet?

    Sonst mal die Plugins deaktivieren und testen
     
  8. suquita

    suquita Member

    Registriert seit:
    20. Juni 2018
    Beiträge:
    11
    Zustimmungen:
    0
    E263CB66-E8D2-4AB3-B84C-2C406D4C7CEA.png ja hab ich
     
  9. suquita

    suquita Member

    Registriert seit:
    20. Juni 2018
    Beiträge:
    11
    Zustimmungen:
    0
    Und wenn ich Ecuador als Beitragsseite definiere, und einen Beitrag zu produkttests schreibe taucht er wo auf? Ausschließlich an auf der Beitragsseite. Obwohl der permalink korrekt ist
     

    Anhänge:

  10. suquita

    suquita Member

    Registriert seit:
    20. Juni 2018
    Beiträge:
    11
    Zustimmungen:
    0
    Danke das hab ich auch schon probiert.
     
    #10 suquita, 20. Juni 2018
    Zuletzt von einem Moderator bearbeitet: 20. Juni 2018
  11. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.343
    Zustimmungen:
    416
    Reise nach Ecuador ist weiterhin als Blog definiert und Produkt-Tests ist eine Seite.

    Kann es sein, dass es bei dir Seiten gibt, die den gleichen Titel haben, wie die Kategorien heißen? Das mag WordPress nicht. Lösch die Seiten (auch im Papierkorb), oder ändere den Slug/Permalink.
     
  12. suquita

    suquita Member

    Registriert seit:
    20. Juni 2018
    Beiträge:
    11
    Zustimmungen:
    0
    Ja, die Seiten heißen wie die Kategorien. Die hab ich aus dem Menü zwar rausgelöscht (und nur die Kategorien drin, aber vielleicht lösch ich Mal die Seiten ganz raus.
    Danke für deine Hilfe.

    Edit SirEctor: Direktzitat gelöscht
     
  13. suquita

    suquita Member

    Registriert seit:
    20. Juni 2018
    Beiträge:
    11
    Zustimmungen:
    0
    DAS war es! Ich hab die Seiten rausgelöscht und auch die Beitragsseite auf -auswählen- zurückgesetzt.
    Jetzt taucht jeder Test-Artikel da auf wo er hin soll. Ganz lieben Dank.
     
  14. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.343
    Zustimmungen:
    416
    Beim nächsten Problem bzw. für Mitleser: schau dir den Quelltext und dort die body-classes an. Daran konnte man gut erkennen, dass es sich um eine page und nicht um eine category gehandelt hat. Das gibt Aufschluss darauf, dass ein Konflikt vorliegt.
     
  15. suquita

    suquita Member

    Registriert seit:
    20. Juni 2018
    Beiträge:
    11
    Zustimmungen:
    0
    Ich kenn mich in wp nicht mit Quelltexten aus, bzw. wo ich die finde (ausser im Beitrag bei 'text') kann "leider" nur mathlab und R coden.
     
  16. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.448
    Zustimmungen:
    243
    Das hat nichts mit WP zu tun, sondern mit Browsern. Einfach auf deiner Site einen Rechtsklick und dann "(Seiten)Quelltext anzeigen" o.ä.
    Bei <body ... siehst du dann alle Klassen.
     
  17. suquita

    suquita Member

    Registriert seit:
    20. Juni 2018
    Beiträge:
    11
    Zustimmungen:
    0
    Ah okay. Im Internet hab ich bisher noch nicht rumgepfuscht :) merk ich mir mal. Danke
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden