1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.4 Twenty Thirteen update und die widgets bei mobilen Browsern sind weg!

Dieses Thema im Forum "Design" wurde erstellt von franke12359, 28. Januar 2016.

  1. franke12359

    franke12359 Member

    Registriert seit:
    8. August 2014
    Beiträge:
    17
    Zustimmungen:
    0
    Hallo,
    ist nicht sofort aufgefallen, aber stört doch erheblich, weil der Veranstaltungskalender und die Werbung im Widget steckt.
    auszuprobieren bei: Berlin-woman.de
    Wenn ich bei android im Browser "Desktop Seite darstellen" anklicke, dann sind die widgets wieder da.
    Twenty Thirteen ist original (kein child)
    Leider habe ich keine Stelle gefunden, wo so etwas einstellbar ist.
     
  2. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    11.768
    Zustimmungen:
    326
    Ich sehe den Kalender und auch die Werbung unter Chrome auf Android. Die Sidebar rutscht nur unter den Content, was aber bei den meisten Responsive Themes so ist.
     
  3. franke12359

    franke12359 Member

    Registriert seit:
    8. August 2014
    Beiträge:
    17
    Zustimmungen:
    0
    Hallo,
    vielen Dank für's nachschauen....
    Vor 20 Minuten habe ich den "Fehler" ja auch durch einen "Quick an dirty hack" beseitigt. ;)
    Ich hatte den Falcon cache abgeschaltet, weil ich an der Seite am Design geändert habe und zu faul war, nach jeder Änderung den cache zu löschen...
    Diesem cache Modul aus dem Wordfence Plugin ist der typ des Browsers egal und es reicht ein Desktop user, um diese Seite dann allen zu geben.
    Soweit der Quick hack ...
    vorher habe ich mich durch den Quelltest von WP gequält und feststellen müssen, das das sidebar Modul aus den theme überhaupt nicht aufgerufen wird, wenn von einem mobilen browser die Seite geholt wird.
    Und - komischerweise - benutzt wp den php Befehl get_browser() nicht, der für den user agent gedacht ist.
    Wie also stellt wp den user agent fest ?

    Nun - egal - ich muß nicht die Welt retten, es funzt ja nun.
    Nochmals vielen Dank für die Mithilfe.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden