Upgrade wegen Trojaner - Probleme mit PlugIns

Dieses Thema im Forum "Installation" wurde erstellt von EV3RW00D, 12. März 2012.

  1. EV3RW00D

    EV3RW00D New Member

    Registriert seit:
    17. Januar 2012
    Beiträge:
    1
    Zustimmungen:
    0
    Hey Leute,

    ich hatte mir bei einem WP 3.1.3 nen fiesen Trojaner eingefangen (Trojan.JS.redirector.oe) und war dadurch gezwungen nen Update "von Hand" zu machen. Hab also die aktuelle 3.3.1 einfach drüberkopiert.

    Front-End läuft wieder, aber wenn ich jetzt meine PlugIns aktualisieren möchte, kommt die Meldung:

    "Fatal error: Class 'Plugin_Upgrader' not found in /mnt/web4/12/74/52030574/htdocs/WordPress_01/wp-admin/update.php on line 62"

    Was kann ich da tun?

    MfG

    Dominik
     
  2. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    3.996
    Zustimmungen:
    3
    "drüberkopieren" als Lösungsweg ist etwas "mager" in der Beschreibung.

    Wenn Dein Wp 3.1.3 Schadcode verteilt - musst du meiner Meinung nach zuerst die Sicherheitslücke finden und das verteilen von Trojaner verhindern.

    Da du keiner Datei auf dem Server mehr trauen kannst - auch keiner Grafik (einige Hacker tarnen ihren Code auch als Grafik(!) ist es ein sinnvoller Weg
    _alles_ zu löschen und eine _saubere_ (Schadcode freie) Version zu kopieren.

    wenn diese WP Version 3.1.3 fehlerfrei läuft kannst du nach dieser Anleitung evtl. ein Upgrade durchführen
    http://doku.wpde.org/Upgrade

    Wobei ein Upgrade von 3.1.3 ein überspringen von
    Version 3.1.4
    Version 3.2.0
    Version 3.2.1
    Version 3.3.0
    zu
    Version 3.3.1 ist.

    und schon sehr gewagt ist. Vermutlich werden nicht
    alle Plugins in der aktuellen Version funktionieren.

    Soweit ich mich erinnere waren dies im letzten Jahr
    einige von denen ich mich verabschieden musste.

    Die Klasse ist in dieser Datei eingentlich verhanden
    ~
    /wp-admin/update.php
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    evtl. stimmt der Pfad in ABSPATH nicht
    oder die Datei ist beschädigt
    oder die Datei fehlt.

    Evtl. hilft es, wenn man die Dateien _löscht_ und erneut per FTP hochlädt.

    Wenn die Datei von dir nicht gelöscht werden kann (falsche Rechte oder unbekannte Benutzer, Gruppe hat - solltest du dich an den Systemadmin wenden.

    Viel Glück

    ralf