1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Vorsicht mit WP 2.1

Dieses Thema im Forum "Installation" wurde erstellt von redunzl, 23. Januar 2007.

  1. redunzl

    redunzl Well-Known Member

    Registriert seit:
    25. Oktober 2004
    Beiträge:
    72
    Zustimmungen:
    0
    Ich habe gerade mein lokalhorst-Testblog auf 2.1. upgedatet. 2 Plugins, die ich schon ewig verwende (pagenavi von www.lesterchan.net und ein eigenes), funktionieren nicht mehr und das Dashboard hat ein paar Parser-Fehler.
    Sollte ich weitere Probleme finden, werde ich das hier ergänzen.
     
  2. redunzl

    redunzl Well-Known Member

    Registriert seit:
    25. Oktober 2004
    Beiträge:
    72
    Zustimmungen:
    0
    Die Plugin-Fehler konnte ich inzwischen beheben.
    (pagenavi.php-Fehler: siehe Forum www.lesterchan.net)

    Die Zeilen 111 und 112 der wp-admin/index.php verursachen den Parser-Fehler:

    Parse error: parse error, unexpected ',' in D:\_htdocs\blog\wp-includes\gettext.php(313) : eval()'d code on line 1
     
    #2 redunzl, 23. Januar 2007
    Zuletzt bearbeitet: 23. Januar 2007
  3. miccom

    miccom Well-Known Member

    Registriert seit:
    2. Juli 2006
    Beiträge:
    193
    Zustimmungen:
    0
    Event. könntest du noch ergänzen mit welchen Plugins du keine Probleme hattest - ich mache selbiges sowie ich fertig bin. :D
     
  4. redunzl

    redunzl Well-Known Member

    Registriert seit:
    25. Oktober 2004
    Beiträge:
    72
    Zustimmungen:
    0
    Das ist natürlich eine heikle Sache. Denn ich kann noch nicht sagen, dass sie alle funktionieren. Sie verursachen zumindest keine sichtbaren Fehler. Das heißt aber nix:

    Advanced Search 0.5
    Character Set Conversion 0.8
    Clean Archives Reloaded 1.0.1
    Comment Quicktags 1.9
    Download Manager R1.beta2_WP2
    DynamicMeta 0.4.1
    Force Word Wrapping 1.0.0
    Kill Refererspam 1.0 (unveröffentlichtes Eigengewächs)
    Lightbox Plugin 0.5 PLUS!
    o42-clean-umlauts 0.2.0
    PHP Exec 1.5
    semmelgalerie 0.2 (unveröffentlichtes Eigengewächs)
    semmelstatz2 2.5 (Eigengewächs)
    Smart Update Pinger 2.0
    Spaltenmacher 0.1 (unveröffentlichtes Eigengewächs)
    Text Replace 1.0
    wbQuiz 0.1.0
    WP-ContactForm 1.4.3
    WP-PageNavi 2.10

    Ich weiß auch nicht, ob der o.g. Fehler eventuell was mit meiner php-Version 5.1.4 (xampp) zu tun hat.
     
  5. MaD

    MaD Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Januar 2006
    Beiträge:
    3.097
    Zustimmungen:
    0
    also hier findest du auch eine Liste mit Plugins und ob sie gehen oder nicht oder noch nicht getestet oder oder
     
  6. Monika

    Monika Well-Known Member
    Ehrenmitglied

    Registriert seit:
    4. Juni 2005
    Beiträge:
    14.126
    Zustimmungen:
    2
    ast jeder Pluginautor hat seine Plugins einem Update unterzogen.

    Einfach auf die Homepage des Lieblingsplugins surfen und dort nachlesen.
    Gibts noch kein Update dann dort den Feed holen und so hat man schnell eine Info, wann es so weit ist

    lg
     
  7. flash

    flash Well-Known Member

    Registriert seit:
    28. Oktober 2005
    Beiträge:
    153
    Zustimmungen:
    0
    Es gibt leider auch einige Plugins die nicht mehr weitergepflegt werden. Manchmal hilft auch eine Suche, ob jemand nicht anderes das Plugin weiterpflegt.
    Aber die Aufforderung vorher ein Backup zu machen kann ich nur unterstreichen.
     
  8. MLS

    MLS Active Member

    Registriert seit:
    14. November 2006
    Beiträge:
    31
    Zustimmungen:
    0
    Mal eine andere Frage:
    Ich habe WP 2.1 ganz neu installiert um ein neues Blog testhalber zu erstellen, bevor ich mir was am alten Blog kaputt mache, aber alle versprochenen Neuerungen sind nicht da. Ich kann nirgends den Editor umstellen, es ist keine Rechtschreibprüfung vorhanden usw. Woran liegt das? Oder bin ich einfach nur blind?
     
  9. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Den Editor kann man z.B. nur umstellen, wenn standardmäßig WYSIWYG aktiviert ist.
     
  10. MLS

    MLS Active Member

    Registriert seit:
    14. November 2006
    Beiträge:
    31
    Zustimmungen:
    0
    Hey,danke. Das ging ja fix.
     
    #10 MLS, 23. Januar 2007
    Zuletzt bearbeitet: 23. Januar 2007
  11. TomsDiner

    TomsDiner Member

    Registriert seit:
    20. September 2006
    Beiträge:
    20
    Zustimmungen:
    0
    DB korrekt?

    Mal eine Frage an diejenigen die WP2.1.0 neu installiert haben: Kann es sein das bei der Installation nicht alle Daten korrekt in die DB geschrieben werden?

    Zum einen hatte ich das Problem das nach der Installation die Benutzer keinen User-Level hatten. Nachdem ich den Benutzern eine Rolle zugeteilt hatte, hatten sie einen Benutzer-Level.
    Zum Anderen hatte ich Probleme mit meinem selbst gestrickten Theme. Da funktionierte die Template-Funktion next_posts_link() plötzlich nicht mehr. Bis ich grade eben noch einmal explizit die Anzahl an Beiträgen eingegeben habe die pro Seite angezeigt werden sollen. Nun funktioniert es.

    Habe WP2.1.0 jetzt zwei mal frisch installiert. Jedes mal das gleiche. Wenn ich manche Optionen nicht explizit noch einmal eingebe und speichere, sind sie quasi nicht vorhanden.

    Ich habe WP2.1.0 frisch installiert, also kein Update! Apache 2.0 & PHP 4.3.9 & MySQL 4.0.20
     
  12. D4nt3

    D4nt3 Active Member

    Registriert seit:
    11. Oktober 2006
    Beiträge:
    33
    Zustimmungen:
    0
    Okay da hänge ich mich mal mit rein.
    Update war ohne Probleme. Soll nicht heißen das man vorher kein Backup der Files und der DB machen muss!!!
    Habe auch direkt alle bei mir eingesetzten Plugins auf aktualität getestet und wenn diese nicht aktuelle waren, direkt geupdatet. Und somit laufen bei mir folgende Plugins "ohne" Probs:
    • Wobei man sagen muss da der Update Monitor nun immer Anzeigt 2.1|2.1.0 und das 2.1.0 in rot?!? checke ich net ganz ist aber so ^^ Hat wer ne Idee???
    PS: Gerade sehe ich das einige Icons im Editor fehlen. Nun habe ich die Icons zu mygallery, imagemanager & dem contact form nicht mehr drinnen :( Weiß einer wie ich das behoben bekomme???
     
    #12 D4nt3, 23. Januar 2007
    Zuletzt bearbeitet: 23. Januar 2007
  13. Monika

    Monika Well-Known Member
    Ehrenmitglied

    Registriert seit:
    4. Juni 2005
    Beiträge:
    14.126
    Zustimmungen:
    2
    Toms Diner
    da das neue WP sehr viel anders als das andere WPist , ist dieses Verhalten normal

    lg
     
  14. Olaf

    Olaf WPDE-Team
    Mitarbeiter

    Registriert seit:
    3. September 2004
    Beiträge:
    2.738
    Zustimmungen:
    29
    ...da hat sich ein Fehlerchen eingeschlichen, daß Problem ist jetzt behoben.
     
  15. TomsDiner

    TomsDiner Member

    Registriert seit:
    20. September 2006
    Beiträge:
    20
    Zustimmungen:
    0

    Also ich finde sowas nicht "normal". Eher befremdlich. Sehr sogar. Schließlich habe ich kein Update gemacht, sondern eine Neuinstallation!
     
  16. fym

    fym Well-Known Member

    Registriert seit:
    4. Januar 2005
    Beiträge:
    161
    Zustimmungen:
    0
    Bezüglich myGallery: Bei meiner testweisen lokalen Neuinstallation von WP 2.1 ging bei diesem Plugin nichts mehr bei mir. Es erstellte nicht mehr bei Aktivierung die eigene Datenbanktabellen (nehme mal an, dass das an $table_prefix liegt). Auch nach dem manuellen Kopieren der Tabellen bekomme ich auf den Optionsseiten der Galerie nur leere Seiten geliefert.

    Beim Update einer bestehenden älteren WP-Version gab es das Problem zumindest nicht.

    ~fym
     
  17. alex.rabe

    alex.rabe Well-Known Member

    Registriert seit:
    18. November 2006
    Beiträge:
    243
    Zustimmungen:
    0
    Siehe :
    http://forum.wordpress-deutschland.org/showthread.php?t=15514

    Ja, einige Autoren müssen Ihre Plugin's überarbeiten, sonst ist zur Zeit nix mit Icon's im TinyMCE. Es gibt aber schon einige die überarbeitet sind...
     
  18. radiovhr

    radiovhr New Member

    Registriert seit:
    30. Oktober 2006
    Beiträge:
    3
    Zustimmungen:
    0
    Hilfeee!

    Ich habe immer noch folgende Fehlermeldung!

    WordPress database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1]
    SELECT cat_id, cat_name FROM

    Was läuft denn da falsch?? Würde mich freuen, wenn Ihr Antworten hättet!

    Danke im Vooraus! (info@radio-vhr.de)
     
  19. D4nt3

    D4nt3 Active Member

    Registriert seit:
    11. Oktober 2006
    Beiträge:
    33
    Zustimmungen:
    0
    Jau danke dir. Na da hilft wohl nur warten :-?
     
  20. venus

    venus Well-Known Member

    Registriert seit:
    13. Januar 2007
    Beiträge:
    688
    Zustimmungen:
    0
    Category Manager

    updaten von 2.0.7 auf 2.1 ging problemlos.
    nur das plugin "Category Manager" will nicht mehr. das heisst: es werden alle kategorien gleich mehrmals untereinander aufgelistet.
    kennt jemand die lösung oder ein anderes plugin zur verwaltung + sortierung von kategorien?

    vielen dank und schöner tag.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden