Weiterlesen-Link wird blockiert

Dieses Thema im Forum "Konfiguration" wurde erstellt von Blogplus.at, 27. September 2012.

  1. Blogplus.at

    Blogplus.at Well-Known Member

    Registriert seit:
    12. August 2012
    Beiträge:
    98
    Zustimmungen:
    0
    Hallo alle miteinander,

    ich habe da ein Problem bei meinem Template das ich nicht lösen kann.

    Mir wird auf der Startseite der Weiterlesen-Link nicht angezeigt.

    Ich kenne mich da nicht so gut aus aber ich gehe mal davon aus das die folgende Funktion das blockiert:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Wenn ich diesen Code aus der funktions.php entferne passiert nichts. Habe zusätzlich noch folgenden Code den ich mittels Google und diesem Forum, in verschiedenen Varianten, finden konnte dazu eingefügt aber auch das hilft mir nicht:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Ich bin Neuling, lerne per Google und Foren aber kenne mich mit diesem Thema noch zu wenig aus.

    Ich möchte einfach auf der Startseite ein "Weiterlesen ->" drauf haben.

    www.blogplus.at <- um diesen Blog geht es.

    Danke schon mal im Voraus.

    Lg
     
  2. reap705

    reap705 Well-Known Member

    Registriert seit:
    18. August 2010
    Beiträge:
    198
    Zustimmungen:
    0
    In deinem Theme wird eine Kurzfassung (excerpt) der Artikel ausgegeben, welche standardmäßig keinen Weiterlesen-Link ausgibt. Wenn du den More-Tag nutzen willst, kannst du die Anzeige der Artikel umstellen. Such mal in der index.php nach <?php the_excerpt(); ?> und ändere das in <?php the_content(); ?>

    Evtl. hat dein Theme dazu ja eine Theme-Option, über die sich das einstellen lässt.

    Eine weitere Möglichkeit wäre die Kurzfassung um einen Weiterlesen-Link zu ergänzen (s. Codex). Dazu fügst du in der functions.php dies hier hinzu:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  3. Blogplus.at

    Blogplus.at Well-Known Member

    Registriert seit:
    12. August 2012
    Beiträge:
    98
    Zustimmungen:
    0
    Hallo reap705, Danke für deine Antwort.

    <?php the_excerpt(); ?> ist bei mir nicht in der index.php sondern in einer anderen Datei. Es gibt bei diesem Template insgesamt 4 verschiedene Post-Types und ich habe die Funktion bei jener geändert, die für den Text ist, also den Post-Type den ich nutze. Hab das dort geändert. Leider kein Ergebnis. (Seitenache gelöscht und Strg +F5 im Browser genutzt).

    Auch der Code den ich in die functions.php eingefügt habe hat nichts daran geändert.

    Sollte ich den Befehl raus löschen wie im ersten Post von mir vermerkt?

    Lg
     
  4. reap705

    reap705 Well-Known Member

    Registriert seit:
    18. August 2010
    Beiträge:
    198
    Zustimmungen:
    0


    Das hast du doch schon ausprobiert, oder hab ich dich da falsch verstanden? Ich würde den Ersteller des Themes kontaktieren.
     
  5. Blogplus.at

    Blogplus.at Well-Known Member

    Registriert seit:
    12. August 2012
    Beiträge:
    98
    Zustimmungen:
    0
    Ja sorry, stimmt. Nach dem Löschen vom Befehl wird mir das Backend nicht mehr angezeigt, hab den Hersteller mal kontaktiert. :)

    Vielen Dank, ich melde mich aber trotzdem wieder wenn ich eine Lösung bekomme, vielleicht kommt noch jemand irgendwann mit dem selben Problem.

    Bis dann.

    Lg