Wordpress Umzug klappt nicht

Dieses Thema im Forum "Installation" wurde erstellt von Gothar, 11. Juli 2006.

  1. Gothar

    Gothar Member

    Registriert seit:
    10. November 2005
    Beiträge:
    21
    Zustimmungen:
    0
    Hallo zusammen!

    Wie hier in den verschiedenen Forenbeiträgen erläutert, habe ich versucht mit meinem Blog auf einen neuen Server umzuziehen.

    Allerdings ist das ganze leicht fehlgeschlagen. Ich habe wie in der Dokumentation die Datenbank gesichert (bis auf die Tabelle "Options", da die ja nicht mit rüberkopiert werden sollte), habe dann alle Wordpress-Dateien komplett auf den neuen Server geladen und habe schließlich die Installation erneut ausgeführt. Dann habe ich die alte Datenbank hochgeladen. Blöderweise zeigt er mir ständig sowohl im Installationsfenster als auch an anderen Stellen folgendes an:

    Warning: Cannot modify header information - headers already sent by (output started at /home/www/web211/html/wp-config.php:23) in /home/www/web211/html/wp-login.php on line 9

    Warning: Cannot modify header information - headers already sent by (output started at /home/www/web211/html/wp-config.php:23) in /home/www/web211/html/wp-includes/pluggable-functions.php on line 247


    Umlaute werden nicht mehr als solche angezeigt und über dem Admin-Tool steht ein langer kryptischer Text, außerdem sind manche Dinge über das Admin-Tool nicht mehr zu erreichen. Was habe ich falsch gemacht? Kann mir jemand helfen?

    Viele Grüße,
    Martin
     
  2. jottlieb

    jottlieb WPD-Team

    Registriert seit:
    20. August 2005
    Beiträge:
    17.382
    Zustimmungen:
    0
    Doch, sollte sie. Ohne diese Tabelle kann das Blog nicht funktionieren.

    Auch keine gute Idee. Schließlich reicht es wenn man, siehe FAQ, in der Tabelle options nur zwei Felder, nämlich die der Adresse ändert.

    Falls danach das Problem mit dem cannot modify header besteht, gib diesen Text mal hier in die Forensuche ein - du wirst genug finden.
     
  3. Gothar

    Gothar Member

    Registriert seit:
    10. November 2005
    Beiträge:
    21
    Zustimmungen:
    0
    So ... das erste Problem ist behoben und das nächste steht an:

    Was die modify header - Geschichten angeht steht hier im Forum oft, dass sich irgendwo eine Leerzeile oder sowas eingeschlichen hat. Leider bin ich dahingehend nicht so der Crack. Wenn ich was posten will kommt jetzt folgende Fehlermeldung:

    WordPress database error: [Duplicate entry '0' for key 1]
    INSERT INTO wp_postmeta (post_id,meta_key,meta_value) VALUES ('0','_pingme','1')

    WordPress database error: [Duplicate entry '0' for key 1]
    INSERT INTO wp_postmeta (post_id,meta_key,meta_value) VALUES ('0','_encloseme','1')


    Warning: Cannot modify header information - headers already sent by (output started at /home/www/web211/html/wp-includes/wp-db.php:102) in /home/www/web211/html/wp-admin/post.php on line 60


    Kann die "Warning"-Meldung auch wieder so eine Leerzeichen-Geschichte sein?

    Die obere Fehlermeldung verstehe ich allerdings gar nicht. Ich habe das mal genauso (also alles in der Klammer inklusive der Klammern) in meine wp_postmeta eingefügt, allerdings meint mein SQL-Tool dann, dass das keine gültigen Befehle seien. Und was mach ich jetzt?

    Wäre es vielleicht günstig, einfach alle Dateien nochmal vom Server zu löschen, den ganzen Backup-Kram vom alten Server nochmal auf den neuen hochzuladen, und dann die Datenbanken hinterher zu schieben? Das Umlaute-Problem bleibt nämlich bei den alten Posts auch noch bestehen.
     
  4. Gothar

    Gothar Member

    Registriert seit:
    10. November 2005
    Beiträge:
    21
    Zustimmungen:
    0
    So ... jetzt hab ich nochmal alles runtergelöscht vom Server, die alten Dateien wieder drauf, die Datenbank-Tabellen vom alten Server importiert, aber leider hats immer noch nicht geklappt. Irgendetwas scheine ich falsch zu machen und ich habe weder im FAQ noch sonstwo eine möglicherweise etwas detailierte Anleitung für einen Umzug gefunden.

    Kann vielleicht irgendjemand einem Laien eine Anleitung zusammenschreiben. Also mir? *grins* Vielleicht auch mit einigen Anmerkungen dazu, auf was man achten muss.

    Dank Euch!

    Gruß,
    Martin
     
  5. Gothar

    Gothar Member

    Registriert seit:
    10. November 2005
    Beiträge:
    21
    Zustimmungen:
    0
    Hallo zusammen!

    So ... hab noch ein wenig weiter gebastelt und es schaut eigentlich ganz gut aus.

    Diesmal habe ich die Datenbanken einzeln exportiert und auch einzeln hochgeladen. Alles läuft ganz hervorragend bis ich die Daten "wp_posts" einfüge. Nachdem diese Datenbank hochgeladen ist, lässt mich Wordpress keinen weiteren Post schreiben, will heißen, ich erstelle einen Post, klicke auf "veröffentlichen" und er sagt mir auch ganz brav, dass der Post gesichert worden ist, aber er erscheint nicht auf der Startseite und auch nicht im "Verwalten"-Menü. Kann sich das jemand erklären?

    Zweites Problem: Füge ich dann die postmeta noch hinzu ist alles im Eimer. Er spuckt dann nämlich beim Schreiben eines Posts folgendes aus:

    WordPress database error: [Duplicate entry '0' for key 1]
    INSERT INTO wp_postmeta (post_id,meta_key,meta_value) VALUES ('0','_encloseme','1')


    Warning: Cannot modify header information - headers already sent by (output started at /home/www/web211/html/wp-includes/wp-db.php:102) in /home/www/web211/html/wp-admin/post.php on line 60

    Wenn diese beiden Dinge behoben sind, läuft alles einwandfrei. Ich bräuchte nur mal jemanden, der mir erklärt, was das für Fehler sind und wie ich sie beheben kann.

    Ich danke Euch!
     
  6. Gothar

    Gothar Member

    Registriert seit:
    10. November 2005
    Beiträge:
    21
    Zustimmungen:
    0
    Ich könnte mir übrigens vorstellen, dass das irgendetwas mit der Vergabe der Post-ID zu tun hat. Meine alten Posts gingen bis ID Nummer 86 und nun wäre es ja net schlecht, wenn es bei 87 weitergeht. Kann es irgendetwas damit zu tun haben?
     
  7. Gothar

    Gothar Member

    Registriert seit:
    10. November 2005
    Beiträge:
    21
    Zustimmungen:
    0
    Ja, es hatte etwas damit zu tun. Ich habe immer schön weiter gebastelt und musste fast alle sql-Datenbanken auf auto_increment umschalten, weil das trotz der exakten Übernahmen der alten Datenbanken auf 0 stand. Weiß jemand wie das sein kann?

    Außerdem hat er mir die alten Posts nicht wieder in die entsprechenden Kategorien zurückgeschoben, sondern als unkategorisiert eingestellt. Weiß da vielleicht auch jemand was?

    Komisch, dass der einfache Weg vom runterziehen, hochladen, Datenbank sichern und ersetzen bei mir so gar nicht funktioniert und ich alles manuel und kompliziert erledigen muss ...

    Ich hoffe, ihr antwortet hier noch fleißig ... ich brauche wissenswerten Input!!